[rails4] rake assets:precompileしようとしたらCurrent ExecJS runtime does’t support ES6. Please install latest Node.jsと怒られる問題の解決法

By | 2018-07-22

自分のrailsアプリをherokuにpushしようとrake assets:precompileをしたら

と怒れら、ニッチもサッチもいかない状態に。

 

いろいろ試行錯誤した結果以下の通りで解決しました。

 

自分は

と最新バージョンで使用していたのですが、これをバージョンダウンして

とし

 

 

したら解決しました。

 

その後コミットすることをお忘れなく。

 

科学と音楽と猫が好きなScientistです。